Downgrade iPhone 3G Firmware 2.2 from 2.2.1 – QuickPwn Jailbreak Update

UPDATE 1: Click here to see how I downgraded from iPhone firmware 2.2.1 to 2.2!

UPDATE 2: iPhone firmware 2.2.1 jailbreak released by QuickPWN.  Click here for information.

The original BccList.com blog posting from yesterday – https://bcclist.com/2009/01/27/downgrading-iphone-2-2/ – has received some pretty good clickthroughs today.  This is obviously a pretty disruptive firmware update that Apple has released.  I have already set-up for my iTunes to not auto update in the future!

Anyways, please let me know if you’ve found a way to downgrade to iPhone software 2.2 from 2.2.1.  Otherwise, I read in the QuickPwn forum (page 6) that the Dev-Team has figured out a jailbreak but not an unlock.

Fair enough – I only plan to jailbreak.  Great work guys.  I hope something is out for the jailbreak within the next day or so!

4 thoughts on “Downgrade iPhone 3G Firmware 2.2 from 2.2.1 – QuickPwn Jailbreak Update

  1. The shift + restore with the 2.2 ipsw file is giving an unknown error for those with an iPhone 3G.

    After the unknown error screen pops after doing shift + restore of the 2.2 ipsw file, you can run QuickPWN 2.2 to jailbreak your phone but it will delete your phones contents. You will be back to firmware 2.2 but – again – all of your contents (contacts, music, videos, etc.) will be gone.

    Once you realize you can’t live without your phone’s contents – my back-up is from 1/16/09 – you can restore to a previously backed up version and you’re phone will be all better again.

    Though, by “all better again,” I mean you’ll have all the contents back on your iPhone 3G but it won’t be jailbroken. The 2.2.1 update should be announced anytime on QuickPWN’s website and/or Dev-Team blog.

  2. i have iphone3g then after update using itunes version 8.0 we receive the sim not recognize, then i donwload your software quickpwn then i try to jailbreak again. but after finish the jailbroken we encounter problem on network. cannot dial the number “no services” but the wifi already connected to my router. please help how to go back my orignal setting, or any solution to solve this case? before 2.0 no 2.2.1

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s